OmniLab - Introduction

OmniLab Help (compiled HTML help) November 2001 Edition
for OmniLab version (release )

written by Igor Kagan

Online version of this help and other resources and updates can be found on OmniLab website :
http://igoresha.virtualave.net/LabVIEW/OmniLab
http://www.biomed.technion.ac.il/vision/Igor/LabVIEW/OmniLab

To navigate this help file, use the Contents and Index tabs to the left of this window.
This help file links to Portable Document Format (PDF) version of the manual:
OmniLabManual.pdf

See also:
ReadMe.txt
Format.txt
Changes.txt
Calibration.txt
Acquisition.txt
Instructions.txt
OnlineProcessing.txt

Known issues.txt

and sample Matlab files
readbin.m
readlvf.m

Overview:

OmniLab is a versatile data acquisition and analysis software package designed specifically for physiological labs. OmniLab is written in LabVIEW® (National Instruments, http://www.ni.com) and works with NI DAQ hardware. While OmniLab basic package already includes many features and options, powerful LabVIEW programming environment and flexible modular structure of OmniLab allow quick and efficient customization and tailoring for even more specific customer's needs. Visit OmniLab website (http://igoresha.virtualave.net/LabVIEW/OmniLab) for more information and updates.

Features:

Up to 16 analog input channels
Output triggers for communication
Variable sampling rate
Switch between "monitoring" and "record" modes
Log the entire experiment to separate file with decimated sampling rate
Streaming-to-disk capabilities
Calibration routine
Various display options
Online data analysis during data acquisition
Mark events in data with time-stamped comments
Full-screen mode
Playback mode
Retrieval and analysis of data blocks according to event comments
Export data regions of interest or whole blocks to ASCII or binary file
Sample Matlab software and source code available for reading and analysis of exported binary files

see also OmniLab data sheet (PDF)


Acquire mode

 Acquire mode: Monitoring and Recording

Front panel in acquire mode


Display mode

 Display mode: Data Retrieval, Analysis and Export

Front panel in display mode


Hotkeys

 Key Navigation - keyboard shortcuts:
OmniLab version

Main window
Escape 	- toggle between full/normal chart(graph) screen
F1	- stop
F2	- start record
F3	- select block comment field
F4	- show selected blocks
F5	- change chart options
F6	- freeze chart
F7	- info
F8	- print chart
Ctrl-F8	- print front panel
Pop-up windows
Escape	- cancel (close window and return to main window)
Enter	- Done/OK


 Controls and Indicators


 Calibration

Controls and Indicators

cbool

done

cclst

error in (no error)

error in is a cluster that describes the error status before this VI executes. If error in indicates that an error occurred before this VI was called, this VI may choose not to execute its function, but just pass the error through to its error out cluster. If no error has occurred, then this VI executes normally and sets its own error status in error out. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

    cbool

            status

    status is TRUE if an error occurred before this VI was called, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

    ci32

            code

    code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

    cstr

            source

    source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

cbool

cancel

c1dclst

input limits (no change)

Enter the input limits settings for the channels selected in the "channels" array control. This determines the input measurement range in volts that each channel is configured for. Leave this empty for hardware default configuration. Each element of this array corresponds to each element of the channel array, and same input limits setting will apply to all channels listed in each element of the channel array. If you want a different input limits setting for each individual channel, they must be listed separately in the channels array, one channel per element.

    cclst

    Enter the input limits setting for the channels selected in the "channels" array control. This determines the input measurement range in volts that each channel is configured for. Leave this empty for hardware default configuration. Each element of the array corresponds to each element of the channel array, and the same input limits setting will apply to all channels listed in each element of the channel array. If you want a different input limits setting for each individual channel, they must be listed separately in the channels array, one channel per element.

      csgl

              high limit

      This is the upper limit of the input measurement range (in volts). The default setting is hardware dependent, usually +5 or +10 volts.

      csgl

              low limit

      This is the lower limit of the input measurement range (in volts). The default setting is hardware dependent, usually +5 or +10 volts.

ci16

device (1)

Enter the device number you assigned to the plug-in data acquisition board or other device when you configured it.

cbool

save cal. file

Save calibration to file (or update previously loaded calibration file)

cbool

acquire

Press to acquire reading for current point

csgl

scan rate

(SGL) scan rate: the number of scans per second to acquire. This is equivalent to the sampling rate per channel. The default input is 1000 scans/sec.

ci32

number of scans to acquire

(I32) number of scans to acquire: The number of scans the VI retrieves from the acquisition buffer each time the loop iterates. The default input is 1000.

cbool

create

Create A and B from readings matrix

csgl

real value

Real-world value corresponding to voltage reading (e.g. pressure, temperature, flow etc., in desired units)

cbool

1

Fill point one of the two calibration points

cbool

2

Fill point two of the two calibration points

cu16

Channel

Channel to calibrate

c2dsgl

read1 real1 read2 real2

    csgl

    Readings matrix (can be edited manually)

cbool

load cal. file

Load existing calibration file. You can append or change calibration in the loaded file.

cbool

change cal. in file

Change/update calibration in the header of previously recorded data file

iclst

error out

error out is a cluster that describes the error status after this VI executes. If an error occurred before this VI was called, error out is the same as error in. Otherwise, error out shows the error, if any, that occurred in this VI. Use the error handler VIs to look up the error code and to display the corresponding error message. Using error in and error out clusters is a convenient way to check errors and to specify execution order by wiring the error output from one subVI to the error input of the next.

    ibool

            status

    status is TRUE if an error occurred, or FALSE if not. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code.

    ii32

            code

    code is the number identifying an error or warning. If status is TRUE, code is a non-zero error code. If status is FALSE, code can be zero or a warning code. Use the error handler VIs to look up the meaning of this code and to display the corresponding error message.

    istr

            source

    source is a string that indicates the origin of the error, if any. Usually source is the name of the VI in which the error occurred.

iclst

transposed waveform graph

Plot of current/last reading

isgl

value read

Voltage reading

ibool

acquisition?

i2dsgl

A B

    isgl

    Calibration matrix - coefficients (A and B in equation y=Ax+B), where x is voltage and y is real-world value

istr

Message Window

ipath

cal path


 SubVIs


OmniLab ReadMe

 ReadMe
=======================================================================
OmniLab                                 	      Updated:
=======================================================================
README

This folder contains source code for OmniLab software,
written in Labview 5.1.1 G Programming Language and
converted to 6.0.2 version

    OmniLab version 4.0
    for MS-Windows 95/98/NT/2000
    written by Igor Kagan
    http://igoresha.virtualave.net/LabVIEW/OmniLab.html

Copyright (c) 1999-2002 Igor Kagan.
All Rights Reserved.

See License.txt for more information.

kigor@tx.technion.ac.il

Dept. of Biomedical Eng.
Technion - IIT
Haifa 32000
Israel

See also:

- OmniLab Help (file OmniLabHelp.chm)
- Format.txt
- Calibration.txt
- Changes.txt
- Acquisition.txt
- Instructions.txt
- readbin.m
- readlvf.m

and OmniLab Manual

http://igoresha.virtualave.net/LabVIEW/OmniLab
http://www.biomed.technion.ac.il/vision/Igor/LabVIEW/OmniLab


OmniLab Help About

 About
This is compiled HTML help file for OmniLab software.

Build

Current version: OmniLab v.

Copyright (c) 1999-2002 Igor Kagan.
All Rights Reserved.

kigor@tx.technion.ac.il

Dept. of Biomedical Eng.
Technion - IIT
Technion City
Haifa 32000
Israel